Saturday, April 11, 2009

Use Client filter to force Communicator R2 update to users PC

Note: Aaron has a great blog on how to setup automatic update

If you like to do it the hard way do it like this ;)

Update from version 3.5.6907.0 to 3.5.6907.9

Make a client filter on the frontend and/or Edge server
Major verion number:3
Minor verion number:5
Build number: 6907
Qfe number:0
Select comparison operation to perform: =
Select action: Block wiht Static URL
Here you can make a custom page or just point to the update


When Communicator log-in users will get this popup saying: “You must update your version of Microsoft Communicator 2007 R2 before you can sign in…………..”


Be patient it can take some time before the client filter is working.

My communicator did’nt download the update automatic and I have check this “Use Microsoft update” doing installation.